How do I download an app?

Downloading an app cannot be easier. Using your mobile phone, navigate to It will take you to a mobile friendly page listing all of our apps. Click the download link next to each app, and you will be redirected to either Nokia Ovi Store (if you have a Nokia), GetJar (If you have a Sony Ericsson) or the iTunes App Store (if you own an iPhone).

How do I know if my mobile phone is compatible?

We've tried to make this part as simple as possible, as we were getting quite a few questions relating to phone compatibility.  So, firstly we've included a list of phones in the 'Student' section which are compatible.

Secondly. you can browse to our website using your mobile phone. The page that loads up will tell you which version of Flash Lite your handset has, and whether your phone is compatible with our apps.  Now it can't be easier than that!!

Thirdly, you can browse to Nokia Ovi Store/GetJar, select your mobile phone and search for our apps. These stores will only list compatible applications for your phone, and hence if your phone is not compatible with our apps then they wont appear in the list of available apps.

To check if your device has Flash 2.0 or above, you can also use the following links.

Flash Lite supported devices (mobile)
Flash Lite supported devices (PDAs)

Compatible Handsets....

I can't get it to work on my phone. Can I have a refund?

Whilst we aim to offer as much support as possible, we believe that this website and websites referenced within contain enough information for customers to discover whether these apps will work on a specific handheld device. Combined with this, the free downloads we provide are there for you to test compatibility with your chosen handset.

With this in mind, and to reduce maintenance costs for ourselves, refunds are given at our sole discretion and in the same form of payment as the original purchase. We invite you to contact us using our Contact Us page for any support queries.

My device doesn't support Flash Lite 2.0 or above. What can I do?

Whilst we wish that the Pocket Revision apps would work on every mobile handset, some older handsets do not support Flash Lite 2.0 or above. Unfortunately, there is nothing we can do about this limitation. Fortunately, there are still lots of devices out there which do support the technology, and most mobile devices sold today and in the future should support it. Our home page provides links to some great mobile phone deals (scroll to the bottom).